ORA-15056, ORA-15221 Errors

Today creating a password file into a ASM I get the next error;

 
oracle@lince-1:...e/prod/server/product/12.1/dbs$
oracle@lince-1:...e/prod/server/product/12.1/dbs$ orapwd file='+data' password=secret dbuniquename=oradb entries=10

OPW-00010: Could not create the password file.
ORA-15056: additional error message
ORA-15221: ASM operation requires compatible.asm of 12.1.0.0.0 or higher
ORA-06512: at line 4

The issue is enough clear, compatible asm requieres a higer value. If check the compatibility like show below;

 
SQL> select name, COMPATIBILITY, DATABASE_COMPATIBILITY from v$asm_diskgroup

NAME                           COMPATIBILITY                                                DATABASE_COMPATIBILITY
------------------------------ ------------------------------------------------------------ ------------------------------------------------------------
REDCONT_1                      10.1.0.0.0                                                   10.1.0.0.0
REDCONT_2                      10.1.0.0.0                                                   10.1.0.0.0
ARCHIVE_1                      10.1.0.0.0                                                   10.1.0.0.0
OCRVTD_DG                      12.1.0.0.0                                                   10.1.0.0.0
ACFS_LOADS                     12.1.0.0.0                                                   10.1.0.0.0
ACFS_UTILITIES                 12.1.0.0.0                                                   10.1.0.0.0
DATA                           10.1.0.0.0                                                   10.1.0.0.0
FRA                            10.1.0.0.0                                                   10.1.0.0.0
ACFS_DIAG                      12.1.0.0.0                                                   10.1.0.0.0

With grid infrastructure user we can change the compatible with the next command;

 
SQL> alter diskgroup DATA set attribute 'compatible.asm'='12.1.0.0.0';

Diskgroup altered.

If check the compatibility again

 

 
SQL> select name, COMPATIBILITY, DATABASE_COMPATIBILITY from v$asm_diskgroup

NAME                           COMPATIBILITY                                                DATABASE_COMPATIBILITY
------------------------------ ------------------------------------------------------------ ------------------------------------------------------------
REDCONT_1                      10.1.0.0.0                                                   10.1.0.0.0
REDCONT_2                      10.1.0.0.0                                                   10.1.0.0.0
ARCHIVE_1                      10.1.0.0.0                                                   10.1.0.0.0
OCRVTD_DG                      12.1.0.0.0                                                   10.1.0.0.0
ACFS_LOADS                     12.1.0.0.0                                                   10.1.0.0.0
ACFS_UTILITIES                 12.1.0.0.0                                                   10.1.0.0.0
DATA                           12.1.0.0.0                                                   10.1.0.0.0
FRA                            10.1.0.0.0                                                   10.1.0.0.0
ACFS_DIAG                      12.1.0.0.0                                                   10.1.0.0.0

Try the create passwd file again;

 
oracle@lince-1:...e/prod/server/product/12.1/dbs$ orapwd file='+data' password=secret dbuniquename=oradb entries=10
oracle@lince-1:...e/prod/server/product/12.1/dbs$

HTH – Antonio NAVARRO

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s