Failed: JDK version is incompatible Error

Today I was installing last PSU GRID/DB for 12.1.0.2, when hit the next error ;Today I was installing last PSU GRID/DB for 12.1.0.2, when hit the next error ;

root@wolf-3:~# opatchauto apply /data/ho/crs/anr/26635815 -oh /cloud/prod/server/121
OPatchauto session is initiated at Tue Dec 5 12:37:27 2017
System initialization log file is /cloud/prod/server/121/cfgtoollogs/opatchautodb/systemconfig2017-12-05_12-37-31PM.log.
Failed: JDK version is incompatible.Please use a jdk version the same as, or later than 16
The result of cluvfy command does not contain OVERALL_STATUS String.
OPATCHAUTO-72050: System instance creation failed.
OPATCHAUTO-72050: Failed while retrieving system information.
OPATCHAUTO-72050: Please check log file for more details.
OPatchauto session completed at Tue Dec 5 12:37:35 2017
Time taken to complete the session 0 minute, 9 seconds
Topology creation failed.

I haven’t clearly the error, but the problem is because of the path where I executed the opatchauto. In my case I moved to $ORACLE_HOME/OPatch.

root@wolf-3:~# cd /cloud/prod/server/121
root@wolf-3:/cloud/prod/server/121# cd OPatch
root@wolf-3:/cloud/prod/server/121/OPatch# ./opatchauto apply /data/ho/crs/anr/26635815 -oh /cloud/prod/server/121

Use a complete path for opatchauto solve the problem too.
HTH – Antonio NAVARRO

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s