Upgrade RMAN Catalog

When I connected to rman catalog for the first time from a new database, I get the next error;

	
RMAN> connect rcvcat rman/rmanpass@mycatalog

connected to recovery catalog database
PL/SQL package RMAN.DBMS_RCVCAT version 11.02.00.03 in RCVCAT database is not current
PL/SQL package RMAN.DBMS_RCVMAN version 11.02.00.03 in RCVCAT database is not current

The problem here is very usual, the catalog version is lower than this new database. You need execute “UPGRADE CATALOG” command, twice times (the second time for confirm). It resolve the issue.

	
RMAN> upgrade catalog;

recovery catalog owner is RMAN
enter UPGRADE CATALOG command again to confirm catalog upgrade

RMAN> upgrade catalog;

recovery catalog upgraded to version 11.02.00.04
DBMS_RCVMAN package upgraded to version 11.02.00.04
DBMS_RCVCAT package upgraded to version 11.02.00.04

RMAN> exit

HTH – Antonio NAVARRO

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s